用bgpcommunity属性实现路由的双路备份


用户有两个网络6.6.6.0和7.7.7.0,
要求:所有访问6网络的数据都通过RTB到RTA,所有访问7.7.7.0的数据都走RTC到RTA,并且互相备份;
实现:通过路由策略在RTA向RTB和RTC通告这两个路由的时候分别赋予不同的community属性,然后在RTB和RTC上通过community属性设置路由的本地优先属性从而达到客户的要求;
[RTA]display current-configuration
Now create configuration...
Current configuration
!
version 1.74
sysname RTA
firewall enable
aaa-enable
aaa accounting-scheme optional
!
acl 100 match-order auto
rule normal permit ip source 6.6.6.0 0.0.0.255 destination any
rule normal deny ip source any destination any
!
acl 110 match-order auto
rule normal permit ip source 7.7.7.0 0.0.0.255 destination any
rule normal deny ip source any destination any
!
interface Aux0
async mode flow
link-protocol ppp
!
interface Ethernet0
!
interface Serial0
clock DTECLK1
link-protocol ppp
ip address 10.1.0.1 255.255.255.0
!
interface Serial1
link-protocol ppp
ip address 10.2.0.1 255.255.255.0
!
interface LoopBack1
ip address 6.6.6.1 255.255.255.0
!
interface LoopBack2
ip address 7.7.7.1 255.255.255.0
!
quit
bgp 100
undo synchronization
network 6.6.6.0 mask 255.255.255.0
network 7.7.7.0 mask 255.255.255.0
peer 10.1.0.2 as-number 200
peer 10.1.0.2 route-policy for6 eXPort
peer 10.1.0.2 advertise-community
peer 10.2.0.2 as-number 200
peer 10.2.0.2 route-policy for7 export
peer 10.2.0.2 advertise-community
!
quit
!
quit
route-policy for6 permit 10
if-match ip address 100
apply community 100:1
quit
route-policy for6 permit 20
if-match ip address 110
apply community 200:1
quit
route-policy for7 permit 10
if-match ip address 100
apply community 200:1
quit
route-policy for7 permit 20
if-match ip address 110
apply community 100:1
!
return
[RTA]dis ip rou
Routing Tables:
Destination/Mask ProtoPref Metric NexthopInterface
6.6.6.0/24 Direct0 0 6.6.6.1 LoopBack1
6.6.6.1/32 Direct0 0127.0.0.1 LoopBack0
7.7.7.0/24 Direct0 0 7.7.7.1 LoopBack2
7.7.7.1/32 Direct0 0127.0.0.1 LoopBack0
10.1.0.0/24 Direct0 0 10.1.0.2 Serial0
10.1.0.1/32 Direct0 0127.0.0.1 LoopBack0
10.1.0.2/32 Direct0 0 10.1.0.2 Serial0
10.2.0.0/24 Direct0 0 10.2.0.2 Serial1
10.2.0.1/32 Direct0 0127.0.0.1 LoopBack0
10.2.0.2/32 Direct0 0 10.2.0.2 Serial1
127.0.0.0/8Direct0 0127.0.0.1 LoopBack0
127.0.0.1/32 Direct0 0127.0.0.1 LoopBack0
[RTA]
[RTA]dis bgp su
PeerStateversion ASMsg-RxMsg-TxQueued-Tx Up/Down
10.1.0.2Established 420035290 00:24:42
10.2.0.2Established 420035290 00:24:43
[RTA]
[RTA]
[RTB]
[RTB]display current-configuration
Now create configuration...
Current configuration
!
version 1.74
sysname RTB
firewall enable
aaa-enable
aaa accounting-scheme optional
!
interface Aux0
async mode flow
link-protocol ppp
!
interface Ethernet0
!
interface Serial0
link-protocol ppp
!
interface Serial1
link-protocol ppp
ip address 10.1.0.2 255.255.255.0
!
interface Serial2
clock DTECLK1
link-protocol ppp
ip address 10.3.0.1 255.255.255.0
ospf enable area 0.0.0.0
!
interface Serial3
link-protocol ppp
!
quit
ospf enable
!
quit
!
bgp 200
undo synchronization
network 10.1.0.0 mask 255.255.255.0

推荐阅读