Solaris 管理员常用命令


SysAdmin Commands

Debugging

truss executable
/* Trace doing of given command ( useful debugging ) */

truss -f -p
/* Using multiple Windows, this can be used to trace setuid/setgid programs */

Arp, ethernet trouble shooting

arp -a .
/* Shows the ethernet address arp table */

arp -d myhost
/* Delete a stale ethernet entry for host myhost */

Disk Commands

du -k .
/* Reports disk space used in Kilobytes */

du -sk .
/* Reports only total disk space used in Kilobytes */

du -sk *|sort -k1,1n
/* Reports total disk space used in Kilobytes in present Directory */

du -ad /var | sort -nr
/* Tells you how big the /var files are in reverse order */

fdformat -d -U
/* Format diskette */

/usr/bin/iostat -E
/* Command to display drives statistics */

/bin/mount -F hsfs -o ro /dev/sr0 /cdrom
/* Mount an ISO 9660 CDROM */

newfs -Nv /dev/rdsk/c0t0d0s1
/* To vIEw the superfblocks available */

prtvtoc /dev/rdsk/c0t0d0s2
/* Disk geometry and partitioning info */

quot -af
/* How much space is used by users in kilobytes */

Driver Parameters

ndd /dev/ip ?
/* Shows IP variables in the kernel */

ndd /dev/ip ip_forwarding
/* Tells you if forwarding is on (=1) */

ndd -set /dev/ip ip_forwarding 1
/* Enables IP forwarding between interfaces */

File Manipulation

Dos2Unix | -ascii
/* Converts DOS file formats to Unix */

split
/* Split files into pieces */

[vi] : %s/existing/new/g
/* Search and Replace text in vi */

[vi] :set nu
/* Set line numbers in vi */

[vi] :set ts=[num]
/* Set tab stops in vi */

File System

cat /dev/null > filename
/* Zero"s out the file without breaking pipe */

dd if=/dev/rdsk/... of=/dev/rdsk/... bs=4096
/* Make a mirror image of your boot disk */

df -k | grep dg| awk "{print $6}" |xargs -n 1 umount
/* Unmount all file systems in disk group dg */

fsck -F ufs /dev/rdsk/c0t0d0s0
/* Check a UFS filesystem on c0t0d0s0 */

fsck -F ufs -y /dev/rdsk/c0t0d0s0
/* Check answering yes to all questions */

fsck -F ufs -o b=97472 /dev/rdsk/c0t0d0s0
/* Check using an alternate super block */

gzip -dc file1.tar.gz | tar xf -
/* Unpack .tar.gz files in place */

gzip -d -c tarball.tgz | (cd /[dir];tar xf - ) &
/* Unpacking tarballs to diff location */

ln [-fhns]
/* Creating hard links and soft links */

ls -la | awk "{ print $5," ",$9 }" | sort -rn
/* File sizes of current directory */

mount -f pcfs /dev/dsk/c0d0p1 /export/dos
/* Mount DOS fdisk partition from Solaris */

mount -F ufs -o rw,remount /
/* Used to remount root to make it writeable */

mount -o remount,logging /spare
/* Re-mount the ro file system rw and turn on ufs logging */

pax -rw . /newdir
/* Efficient alternative for copying directories */

prtvtoc /dev/rdsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2
/* Cloning Partitiontables */

tar cvf filename.tar
/* Create a tape (tar) archive */

tar xvf filename.tar
/* Extract a tape (tar) archive */

tar cf - . | (cd /newdir ; tar xf -)
/* Recursively copy files and their permissions */

/sbin/uadmin x x
/* Syncs File Systems and Reboots systems fast */

zcat [cpio file] | cpio -itmv
/* Show the contents of a compressed cpio */

zcat /* Extract the patch_file that is a compressed tar file */

File Transfer

get filename.suffix |"tar xf -"
/* Undocumented Feature of FTP */

put "| tar cf - ." filename.tar
/* Undocumented Feature of FTP */

find . -depth | cpio -pdmv /path/tobe/copied/to
/* Fast alternative to cp -pr */

sendport
/* Transferring large numbers of files within the same ftp control session */

General

推荐阅读